Monday, May 7, 2012

Fix for "Can not log on locally to WebRole with virtual directory password"

Recently after a domain password change, I got the following error in trying to run the webrole. 
Can not log on locally to WebRole as user "domain\username" with virtual directory password 
Resolving this error is simple. 
1. Open IIS Manager
2. Select the site. Default Web site in my case and click "Basic Settings..."
3. This opens the Edit Site dialog.Click "Connect as". 
4. In the Connect As dialog, click Set and provide the new password in the Set Credentials dialog. 
5. Come back to Edit Site dialog and click "Test Settings..."
6. Once the connections succeeds, you should be able to successfully open the site in your browser.

16 comments:

Anonymous said...

Thank you!

Jay said...

yes. thank you! i haven't kept up with the layout changes to iis over the years since i use it so sparingly.

Paulmichael said...

This appears to have solved my issue when the domain administrator account password changed. I picked the "Application" option instead, so that it won't matter if they change the domain admin's password - it just logs on locally. Thank you, you have saved me from quite a headache.

Unknown said...

Helped me out, much appreciated.

Unknown said...

Thank u so much. It help out me

Unknown said...

This really helped me out. Thanks for posting this!

Unknown said...

i've tried this and the connection test succeeds but it still wont work.

Angela said...

Worked a charm, thank you!
I was updating the user after my domain password expired at my site, but I had to do the default web site too before it worked

harinath said...

Thank you Very much. Everything was working properly and it stopped working after password expiry and reset. This helped me to fix it. If yours is same problem, then it will help you.

Black Light said...

Thanks, still helping people four years later :)

s said...

Thank you very much. It worked.

Tommy said...

Thank you, This is very helpful.

Shailesh said...

Thanks a ton! AD password was locked. Resolved now

Elena Woo said...

Thanks a million!

Unknown said...

Thanks for such a great solution

Unknown said...

Thanks a lot,

we worked three days on this issue before I found this solution.
Regrards,